yarn’s memo

yarn のバージョンアップで気付いたので、メモ
As I noticed in version up of yarn

きっかけ / Trigger

yarn の最新バージョンを知ったので、バージョンアップしてみたら、更新されなかった。
Since I knew the latest version of yarn, I did not update it as I upgraded it.

➜ ~ yarn -v

yarn v1.2.1 ==> v1.3.2 になるはずだった
It was supposed to be yarn v1.2.1 ==> v1.3.2

試行錯誤 / Trial And Error

➜ ~ npm install yarn -g
/Users/Account/.nodebrew/node/v8.4.0/bin/yarnpkg -> /Users/Account/.nodebrew/node/v8.4.0/lib/node_modules/yarn/bin/yarn.js
/Users/Account/.nodebrew/node/v8.4.0/bin/yarn -> /Users/Account/.nodebrew/node/v8.4.0/lib/node_modules/yarn/bin/yarn.js
+ yarn@1.3.2
added 1 package in 1.842s
➜ ~ yarn -v
1.2.1
➜ ~

バージョンアップされない。 / Not upgraded.

➜ ~ brew uninstall yarn
Uninstalling /usr/local/Cellar/yarn/1.3.2… (14 files, 3.9MB)
➜ ~ brew install yarn
Updating Homebrew…
==> Downloading https://yarnpkg.com/downloads/1.3.2/yarn-v1.3.2.tar.gz
🍺 /usr/local/Cellar/yarn/1.3.2: 14 files, 3.9MB, built in 1 second
➜ ~

バージョンアップされない。 / Not upgraded.

原因 / Cause

.yarn, .yarnrc が古いバージョンを示していた模様。
It seems that .yarn, .yarnrc indicated the old version.

対策 / CounterPlan

➜ ~ mv .yarn back.yarn
➜ ~ mv .yarnrc back.yarnrc

上記コマンド実行後、確認したら直った。
After execution of the above command, I fixed it after confirming it.

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください