eclipseとxamppとphpでハマった件。その2

前回行った環境(Windows7 64bit版)で、セットアップした環境と同じ手順で
別の環境(Windows XP 32bit版)を行って、ソースを稼働させたら、接続エラー!!!!

何?何?DBは同じに構築したし、ユーザー名,パスワードも同じだし・・・・(><)
エラー内容を確認すると、Microsoft® SQL Server® 2012 Native Clientがうんぬんかんぬん・・・・(-”-;;;
あれ?!あれれ?!

調べたら、Microsoft® SQL Server® 2012 Native Clientって、
Windows XP 32bit版サポートしてない!!!

何故?!何故?!

理由
eclipse:pleiades-e4.3-ultimate-32bit-jre_20130626.zip
xampp:同梱 xampp-win32-1.8.1
PHP:5.4.26
Compiler:MSVC9(Visual C++ 2008)
PDO:php_pdo_sqlsrv_54_ts.dll,php_sqlsrv_54_ts.dll

ってなワケで、WindowsXPで使える&デバッグできる環境作り!
eclipse:pleiades-e4.3-ultimate-32bit-jre_20130626.zip
上記pleiadesだと、xampp-win32-1.8.1で、
これまたWindowsXPで動かない?

なので、動くようにしちゃえばいい!!!!
と云う事なので、xamppを変えちゃう!

ダウンロードしたのは、このバージョン
xampp-win32-1.7.7-VC9

このバージョンで、当然このPDOバージョンは動かないので、
(PDO:php_pdo_sqlsrv_54_ts.dll,php_sqlsrv_54_ts.dll)
下記バージョンに変更
(PDO:php_sqlsrv_53_ts_vc9.dll,php_pdo_sqlsrv_53_ts_vc9.dll)

また、extフォルダのDLLバージョンも合わせないと悪夢が甦るので
これまたあわせる為にDLLをコピー
(php-5.3.28-Win32-VC9-x86)

こんな感じで動くようになりました!!!!
※php.ini追記部分は省略しました
xampp177

Add a Comment

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です